[icinga-checkins] icinga.org: icinga-doc/master: docs issue #1774: idoutils upgrade / OCILIB 3.9.2 for Oracle

git at icinga.org git at icinga.org
Wed Aug 24 15:28:27 CEST 2011


Module: icinga-doc
Branch: master
Commit: e8da3696f4b5734f84d5eee3f9f04e97a8c786a6
URL:    https://git.icinga.org/?p=icinga-doc.git;a=commit;h=e8da3696f4b5734f84d5eee3f9f04e97a8c786a6

Author: Wolfgang <wnd at gmx.net>
Date:   Mon Aug 15 22:18:54 2011 +0200

docs issue #1774: idoutils upgrade / OCILIB 3.9.2 for Oracle

---

 de/quickstart-idoutils.xml |    4 ++++
 de/upgrading_idoutils.xml  |   19 +++++++++++++++++++
 en/quickstart-idoutils.xml |    8 +++++++-
 en/upgrading_idoutils.xml  |   19 +++++++++++++++++++
 4 files changed, 49 insertions(+), 1 deletions(-)

diff --git a/de/quickstart-idoutils.xml b/de/quickstart-idoutils.xml
index e6813ad..c378f51 100644
--- a/de/quickstart-idoutils.xml
+++ b/de/quickstart-idoutils.xml
@@ -111,6 +111,10 @@
 
     <listitem>
       <para>installieren Sie statt des libdbi-Treibers den ocilib-Treiber</para>
+      <note><para>Zum Einsatz von &name-idoutils; 1.5.0 mit &name-oracle; benötigen Sie OCILIB 3.9.2 - installieren Sie nicht 3.9.0 oder
+      3.9.1, denn diese Version sind fehlerbehaftet.</para></note>
+      <note><para>Detailliertere Informationen zu &name-idoutils; mit &name-oracle; finden Sie in unserer Wiki-HowTo-Serie zu
+      <link xlink:href="https://wiki.icinga.org/display/howtos/Icinga+and+Oracle">&name-oracle;</link>.</para></note>
     </listitem>
   </itemizedlist>
 
diff --git a/de/upgrading_idoutils.xml b/de/upgrading_idoutils.xml
index 525f2a5..bd706f2 100644
--- a/de/upgrading_idoutils.xml
+++ b/de/upgrading_idoutils.xml
@@ -56,6 +56,25 @@
  $ sqlplus dbuser/dbpass
  SQL> @oracle-upgrade-<version>.sql</programlisting></para>
 
+  <anchor xml:id="upgrading_idoutils_1.5" />
+
+  <para><emphasis role="bold">Aktualisierung der &name-idoutils; auf 1.5</emphasis></para>
+
+  <para><emphasis role="bold">Oracle</emphasis></para>
+
+  <note><para>Zum Einsatz von &name-idoutils; 1.5.0 mit &name-oracle; benötigen Sie OCILIB 3.9.2 - installieren Sie nicht 3.9.0 oder
+  3.9.1, denn diese Version sind fehlerbehaftet.</para></note>
+
+  <para>Passen Sie <filename>oracle-upgrade-1.5.0.sql</filename> an und definieren Sie Ihre Tablespaces ähnlich den folgenden Zeilen. Sie
+  können auch Ihre bestehenden Tablespace-Namen für alle Definitionen benutzen.
+  <programlisting> /* set real TBS names on which you have quota, no checks are implemented!*/
+ define DATATBS='icinga';
+ define LOBTBS='icinga';
+ define IXTBS='icinga';</programlisting></para>
+
+  <note><para>Detailliertere Informationen zu &name-idoutils; mit &name-oracle; finden Sie in unserer Wiki-HowTo-Serie zu
+  <link xlink:href="https://wiki.icinga.org/display/howtos/Icinga+and+Oracle">&name-oracle;</link>.</para></note>
+
   <anchor xml:id="upgrading_idoutils_1.4" />
 
   <para><emphasis role="bold">Aktualisierung der &name-idoutils; auf 1.4</emphasis></para>
diff --git a/en/quickstart-idoutils.xml b/en/quickstart-idoutils.xml
index 1d6a120..2c4e36e 100644
--- a/en/quickstart-idoutils.xml
+++ b/en/quickstart-idoutils.xml
@@ -97,7 +97,13 @@
 
   <para><emphasis role="bold">Oracle Database Support</emphasis></para>
 
-  <para>If you want Oracle as RDBM you'll need to install ocilib instead of libdbi.</para>
+  <para>If you want Oracle as RDBMS you'll need to install ocilib instead of libdbi.</para>
+
+  <note><para>Using &name-idoutils; 1.5.0 with &name-oracle; requires at least OCILIB 3.9.2 - don't install 3.9.0 or 3.9.1 as they
+  remain buggy.</para></note>
+
+  <note><para>More detailed instructions using &name-idoutils; with &name-oracle; you can find in our wiki howto series about
+  <link xlink:href="https://wiki.icinga.org/display/howtos/Icinga+and+Oracle">&name-oracle;</link>.</para></note>
 
   <itemizedlist>
     <listitem>
diff --git a/en/upgrading_idoutils.xml b/en/upgrading_idoutils.xml
index 02925eb..66f8f73 100644
--- a/en/upgrading_idoutils.xml
+++ b/en/upgrading_idoutils.xml
@@ -54,6 +54,25 @@
  $ sqlplus dbuser/dbpass
  SQL> @oracle-upgrade-<version>.sql</programlisting></para>
 
+  <anchor xml:id="upgrading_idoutils_1.5" />
+
+  <para><emphasis role="bold">Upgrading &name-idoutils; to 1.5</emphasis></para>
+
+  <para><emphasis role="bold">Oracle</emphasis></para>
+
+  <note><para>Using &name-idoutils; 1.5.0 with &name-oracle; requires at least OCILIB 3.9.2 - don't install 3.9.0 or 3.9.1 as they
+  remain buggy.</para></note>
+
+  <para>Modify <filename>oracle-upgrade-1.5.0.sql</filename> and set the tablespaces for DATA, LOB, and IXT similar to the following lines.
+  You can provide your existing tablespace names for all defines.
+  <programlisting> /* set real TBS names on which you have quota, no checks are implemented!*/
+ define DATATBS='icinga';
+ define LOBTBS='icinga';
+ define IXTBS='icinga';</programlisting></para>
+
+  <note><para>More detailed instructions using &name-idoutils; with &name-oracle; you can find in our wiki howto series about
+  <link xlink:href="https://wiki.icinga.org/display/howtos/Icinga+and+Oracle">&name-oracle;</link>.</para></note>
+
   <anchor xml:id="upgrading_idoutils_1.4" />
 
   <para><emphasis role="bold">Upgrading &name-idoutils; to 1.4</emphasis></para>





More information about the icinga-checkins mailing list