[icinga-checkins] icinga.org: icingaweb2/master: Remove Zend version check

git at icinga.org git at icinga.org
Thu Nov 13 14:34:41 CET 2014


Module: icingaweb2
Branch: master
Commit: 4595b5131858809d830b3d014fa04a106b02947b
URL:    https://git.icinga.org/?p=icingaweb2.git;a=commit;h=4595b5131858809d830b3d014fa04a106b02947b

Author: Johannes Meyer <johannes.meyer at netways.de>
Date:   Thu Nov 13 14:34:04 2014 +0100

Remove Zend version check

refs #7464

---

 modules/setup/library/Setup/WebWizard.php |   15 ---------------
 1 file changed, 15 deletions(-)

diff --git a/modules/setup/library/Setup/WebWizard.php b/modules/setup/library/Setup/WebWizard.php
index 9c5ec76..c33fceb 100644
--- a/modules/setup/library/Setup/WebWizard.php
+++ b/modules/setup/library/Setup/WebWizard.php
@@ -5,7 +5,6 @@
 namespace Icinga\Module\Setup;
 
 use PDOException;
-use Zend_Version;
 use Icinga\Web\Form;
 use Icinga\Web\Wizard;
 use Icinga\Web\Request;
@@ -384,20 +383,6 @@ class WebWizard extends Wizard implements SetupWizard
             sprintf(mt('setup', 'You are running PHP version %s.'), $phpVersion)
         );
 
-        // The only reason for requiring 1.12.2 is a bug in Zend_Form_Decorator_ViewHelper in older versions causing a
-        // Zend_Form_Element_Button's value not being rendered. Feel free to adjust this in case we require an earlier
-        // version!
-        $zendVersion = Zend_Version::VERSION;
-        $requirements->addMandatory(
-            mt('setup', 'Zend Framework 1'),
-            mt(
-                'setup',
-                'Icinga Web 2 requires at least Zend Framework 1.12.2 to work properly.'
-            ),
-            Zend_Version::compareVersion('1.12.2') !== 1,
-            sprintf(mt('setup', 'You have got Zend Framwork %s installed.'), $zendVersion)
-        );
-
         $defaultTimezone = Platform::getPhpConfig('date.timezone');
         $requirements->addMandatory(
             mt('setup', 'Default Timezone'),



More information about the icinga-checkins mailing list