[icinga-checkins] icinga.org: icinga2/master: Packages: Change ido-pgsql dependency to Postgresql >= 8.4

git at icinga.org git at icinga.org
Wed Dec 14 16:36:30 CET 2016


Module: icinga2
Branch: master
Commit: 5c4b99f92815c8f83fac56be0b890b61d7b7342a
URL:    https://git.icinga.org/?p=icinga2.git;a=commit;h=5c4b99f92815c8f83fac56be0b890b61d7b7342a

Author: Michael Friedrich <michael.friedrich at icinga.com>
Date:   Wed Dec 14 15:23:58 2016 +0100

Packages: Change ido-pgsql dependency to Postgresql >= 8.4

Same as our build server does already.

fixes #13573

---

 icinga2.spec |    6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/icinga2.spec b/icinga2.spec
index 43b9433..7b9e630 100644
--- a/icinga2.spec
+++ b/icinga2.spec
@@ -94,7 +94,7 @@ BuildRequires: libedit-devel
 BuildRequires: ncurses-devel
 %if "%{_vendor}" == "suse" && 0%{?suse_version} < 1210
 BuildRequires: gcc48-c++
-BuildRequires: libstdc++47-devel
+BuildRequires: libstdc++48-devel
 BuildRequires: libopenssl1-devel
 %else
 BuildRequires: gcc-c++
@@ -189,7 +189,11 @@ IDOUtils schema >= 1.12
 %package ido-pgsql
 Summary:      IDO PostgreSQL database backend for Icinga 2
 Group:        Applications/System
+%if "%{_vendor}" == "suse" && 0%{?suse_version} < 1210
+BuildRequires: postgresql-devel >= 8.4
+%else
 BuildRequires: postgresql-devel
+%endif
 Requires: %{name} = %{version}-%{release}
 
 %description ido-pgsql



More information about the icinga-checkins mailing list