[icinga-users] Can't find libdbi when running configure

John.Greenhalgh at ses.com John.Greenhalgh at ses.com
Tue Aug 18 12:01:27 CEST 2009


Michael Friedrich <michael.friedrich at univie.ac.at> wrote on 17/08/2009 
22:39:11:

> 
> Hi,
> 
> seems kind of weird, how did you install the libdbi (from which 
> repo). Did the libdbi-dbd-mysql install the libdbi-drivers as well -
> yum list installed *libdbi*
>

Hi Michael - I installed the packages from Red Hat Network rather than 
yum. There wasn't a libdbi-drivers package, but I thought that was just a 
package of drivers of which libdbi-dbd-mysql was an element? Is that the 
problem?

 
> What is in your /usr/lib/dbd (/usr/lib64/dbd in case)?
>

[root at srv-nms02 dbd]# ls
libmysql.a  libmysql.la  libmysql.so
 
> And what tells ldd on the libdbdmysql.so ?
>

I don't see libdbdmysql.so but for libmysql.so:

[root at srv-nms02 dbd]# ldd libmysql.so
        libmysqlclient.so.10 => /usr/lib/mysql/libmysqlclient.so.10 
(0x00304000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00896000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00cd7000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x0025a000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x00dbe000)
        libm.so.6 => /lib/tls/libm.so.6 (0x00f4a000)
        /lib/ld-linux.so.2 (0x00823000)
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20090818/c72b3035/attachment-0001.html>


More information about the icinga-users mailing list