[icinga-users] Icinga 1.2.0 web crashes

Ståle Johnsen stale.johnsen at gmail.com
Tue Oct 19 10:32:04 CEST 2010


Hi,
I'm having problems with Icinga 1.2.0 web. Classic web, IDO and core seems
to work as expected. I can display the users etc in the web but nothing
else. When I try to click the host status the web reloads with an cannot
connect to webserver error.

Apache errorlog spits out:
[Tue Oct 19 10:23:05 2010] [notice] child pid 28025 exit signal Segmentation
fault (11)
[Tue Oct 19 10:23:05 2010] [notice] child pid 28054 exit signal Segmentation
fault (11)
[Tue Oct 19 10:23:05 2010] [notice] child pid 29016 exit signal Segmentation
fault (11)
[Tue Oct 19 10:23:05 2010] [notice] child pid 29025 exit signal Segmentation
fault (11)
[Tue Oct 19 10:23:05 2010] [notice] child pid 29026 exit signal Segmentation
fault (11)

And the web log shows:

Uncaught AppKitPHPError: PHP Error Invalid argument supplied for foreach()
(/usr/local/icinga-web/app/modules/Cronks/models/System/MonitorPerformanceDataModel.class.php:90)
(/usr/local/icinga-web/app/modules/AppKit/lib/logging/AppKitExceptionHandler.class.php:20)


I found a bug on this, but it seems to be related to postgres which i'm not
using.

https://dev.icinga.org/issues/827

I'm using Ubuntu 8.04 64bit and Mysql.

Regards.

Stale Johnsen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20101019/27029316/attachment.html>


More information about the icinga-users mailing list