[icinga-users] Problems getting Icinga Web Working

Adamec, Tim tadamec at paypal.com
Thu Sep 9 22:21:26 CEST 2010


Hello,

I tweeted yesterday about a problem I was having getting icinga-web up and running for a project and was directed here for some help. I have to say, great response idea with Twitter; I never would have thought of it.

Anyway, I have a project I'm working on and have specced Icinga as a monitoring end-point in our environment. Our standard build is Red Hat Enterprise Linux 5.4 with minimal packages installed in the production environment. I'm building my proof-of-concept on my development machine running CentOS 5.4 with a base set of packages to match, plus development tools and assorted other packages that won't be on the regular production machines.

I've been successful in getting the base Icinga suite running, including the CGI-based interface, but the Web package is giving me fits. Everything appears to install correctly, I can get the login page, but the stock "root/password" login refuses to authenticate. I've tried doing the "make icinga-reset-password" from the build directory several times, and even tried to insert a password manually using a salted SHA256 HMAC; nothing seems to work.

I've found a couple of notes on the web stating that PCRE 7.2 is a minimum requirement. I've installed PHP 5.2.x from the EPEL testing repository, and tried compiling PHP from source into my own directory with a statically-linked PCRE 8.x build and that didn't seem to work either.

Any hints?

Thanks!





More information about the icinga-users mailing list