[icinga-users] incompatible checkConfig

Leandro Batlle leandro.batlle at gmail.com
Thu Sep 16 00:41:30 CEST 2010


Hello people,

Since I'm new to the list, my congratulations and gratitude are in order to
developers and  contributors!

Here's my question: After a fresh install of all the components Icinga-web
doesn't work. Did I do something wrong? Is it a bug?

Might be variant of the not-showing-hosts problem ... I can log in to
icinga-web and all views remain unpopulated, but I get a flood of popups
claiming “internal error”. With the corresponding nsm_log entry:

Uncaught AppKitPHPError: PHP Error Declaration of
IcingaApiConnectionDatabase::checkConfig() should be compatible with that of
IcingaApiConnection::checkConfig()
(/usr/local/icinga/share/icinga-api/objects/connection/IcingaApiConnectionDatabase.php:10)
(/usr/local/icinga-web/app/modules/AppKit/lib/logging/AppKitExceptionHandler.class.php:20)


Context info:

   - Icinga+ido2db works fine: classic interface looks normal, and icinga
   database is populated.


   - Ubuntu Server 10.04


   - All components are in the same box.


   - Standard paths, names, passwords, ports, etc


   - Cloned icinga-web and followed
   icinga-1.0.3/html/docs/en/icinga-web-scratch.html


   -  php icinga-web/bin/testdeps.php output is OK (except  for pgsql and
   memory_limit)



Thanks in advance,

Leandro
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20100915/6aebf511/attachment.html>


More information about the icinga-users mailing list