[icinga-users] Icinga-Web stuck loading

Khoury Brazil kbrazil at sditcs.com
Tue Sep 21 03:44:44 CEST 2010


Hi,

I've installed icinga-web from the git master and seem to be stuck. When I
authenticate with the default user it opens the main page with the bottom
section (log) just 'Loading...' forever. If I attempt to load any of the
panels from the Data section I get more of the same. When I run 'php
icingaWebTesting.php' I get this:

PHPUnit @package_version@ by Sebastian Bergmann.

-> 500 internal server error!

=== Error ===
Uncaught exception AppKitPHPError thrown!

=== Message ===
PHP Error
parse_ini_file(/usr/local/icinga-web/etc/..//etc/tests/test.properties):
failed to open stream: No such file or directory
(/usr/local/icinga-web/etc/tests/tests/installation/userRightsTest.php:10)

=== Stacktrace ===
#0 [internal function]: AppKitExceptionHandler::phpErrorException(2,
'parse_ini_file(...', '/usr/local/icin...', 10, Array)
#1
/usr/local/icinga-web/etc/tests/tests/installation/userRightsTest.php(10):
parse_ini_file('/usr/local/icin...')
#2
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestCase.php(701):
userRightsTest->setUp()
#3
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestResult.php(687):
PHPUnit_Framework_TestCase->runBare()
#4
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestCase.php(653):
PHPUnit_Framework_TestResult->run(Object(userRightsTest))
#5
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestSuite.php(757):
PHPUnit_Framework_TestCase->run(Object(PHPUnit_Framework_TestResult))
#6
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestSuite.php(732):
PHPUnit_Framework_TestSuite->runTest(Object(userRightsTest),
Object(PHPUnit_Framework_TestResult))
#7
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestSuite.php(675):
PHPUnit_Framework_TestSuite->run(Object(PHPUnit_Framework_TestResult),
false, Array, Array, false)
#8
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/Framework/TestSuite.php(675):
PHPUnit_Framework_TestSuite->run(Object(PHPUnit_Framework_TestResult),
false, Array, Array, false)
#9
/usr/local/icinga-web/lib/agavi/src/vendor/PHPUnit/TextUI/TestRunner.php(350):
PHPUnit_Framework_TestSuite->run(Object(PHPUnit_Framework_TestResult),
false, Array, Array, false)
#10 /usr/local/icinga-web/lib/agavi/src/testing/AgaviTesting.class.php(101):
PHPUnit_TextUI_TestRunner->doRun(Object(AgaviTestSuite), Array)
#11 /usr/local/icinga-web/etc/tests/icingaWebTesting.php(66):
AgaviTesting::dispatch(Array)

Any ideas?

Thanks,
Khoury
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20100920/bb057114/attachment.html>


More information about the icinga-users mailing list