[icinga-users] icinga-web (1.5.0/1.5.1) does not display info icons

Philipp Herz - Profihost AG p.herz at profihost.ag
Tue Aug 30 13:09:10 CEST 2011


Hello,

as long as we are using icinga-web (1.4.1) HostStatus and ServiceStatus 
views display nice and useful icons in "Info" column like "flapping.png" 
or "downtime.png".

After upgrading icinga-web to 1.5.0 (also compared 1.5.1) those icons 
are no longer displayed. As far as I can see from the XML templates, 
there is just a "minor" change like

icinga-host-template:
<parameter name="class">IcingaTemplateDisplayServiceIcons</parameter> 
    (1.4.1)
<parameter name="class">CronkGridTemplateDisplayServiceIcons</parameter> 
   (1.5.0/1.5.1)

icinga-service-template:
<parameter name="class">IcingaTemplateDisplayServiceIcons</parameter> 
    (1.4.1)
<parameter name="class">CronkGridTemplateDisplayServiceIcons</parameter> 
   (1.5.0/1.5.1)

So a new "userFunc" is targeted to be used now. This function should be 
able to determine the desired icons by "method" parameter, which can be 
either "hostIcons" or "serviceIcons". Further investigation lead me to 
the corresponding class file which always returns NULL from private 
function "buildIcons".

Is there work in progress to get icons? where to start to get this 
working again? Any hint would be nice ...


Changing XML template files back to the "old way" is impossible, because 
the old class is no longer available.


Philipp




More information about the icinga-users mailing list