[icinga-users] Fixed: Re: where does the icinga-web 1.8.1 log go to when using configure option --with-log-dir=log

Linux IT Services Support support at linux-it-services.nl
Thu Dec 13 18:38:17 CET 2012


While re-reading the configure options, I noticed that a trailing / was 
written in the help

   --with-log-dir=PATH     Folder where to store log files (default log/)

So I ran configure again using --with-log-dir=log/ this time.

This fixed this error.




On 12/13/2012 05:45 PM, Linux IT Services Support wrote:
> Hello,
>
>
> I upgraded icinga-web from 1.7.1 to 1.8.1.
>
> I used the following configure arguments:
>
> --prefix=/usr/local/icinga-web --with-web-user=apache
> --with-web-group=apache --with-web-path=/icinga-web
> --with-web-apache-path=/etc/httpd/conf.d --with-db-type=mysql
> --with-db-host=localhost --with-db-port=3306 --with-db-name=icinga_web
> --with-db-user=icinga_web --with-db-pass=*******
> --with-conf-dir=etc/conf.d --with-log-dir=log
>
> I used --with-log-folder=log in my previous 1.7.1 configure, but for
> 1.8.1 it gave me the following warning:
>
> configure: WARNING: unrecognized options: --with-log-folder
>
> So, I checked the options and used --with-log-dir instead, assuming it
> had changed.
>
> I installed with make upgrade (I previously updated icinga to 1.8.3 and
> updated the database with
> mysql -p icinga < mysql-upgrade-1.8.0.sql, because I used 1.7.1 previously)
>
>
> At the start screen (where I expect to see the login screen), I get this
> message:
>
>
> Uncaught AgaviLoggingException thrown:
> Cannot open file "log/debug-2012-12-13.log", please check permissions on
> file or directory.
>
>
> The logging is normally in /usr/local/icinga-web/log. The log files were
> written there with the previous release without problems.
>
>
> The permissions are ok:
>
>
> drwxr-xr-x. 2 apache apache 4096 Dec 13 17:01 log
>
>
> The webserver runs as apache.
>
> apache   18407 18405  0 16:48 ?        00:00:02 /usr/sbin/httpd
>
>
> Selinux runs in permissive mode.
>
>
> When su'ing to apache (temporary enabled for testing) I can create a
> file in that directory without a problem.
>
>
> So my guess is that icinga-web tries to write to another location,
> because I did not specify a absolute path to the --with-conf-dir option.
> However I do not know how to find out where that location is.
>
>
> The classic UI seems to work OK.
>
>
> Any advise on how to solve this is appreciated.
>
>
> Thanks,
>
>
> Hans Feringa
>
>
>
>
>
>
>
>
>
> ------------------------------------------------------------------------------
> LogMeIn Rescue: Anywhere, Anytime Remote support for IT. Free Trial
> Remotely access PCs and mobile devices and provide instant support
> Improve your efficiency, and focus on delivering more value-add services
> Discover what IT Professionals Know. Rescue delivers
> http://p.sf.net/sfu/logmein_12329d2d
> _______________________________________________
> icinga-users mailing list
> icinga-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/icinga-users





More information about the icinga-users mailing list