[icinga-users] Icinga-Web Jasperserver Integration Broken

David Earp morbiddk at gmail.com
Fri Feb 17 16:39:58 CET 2012


Hello,

I recently upgraded my Icinga-Web from 1.6.0 to 1.6.1 recently and it looks
as thought the Jasperserver integration has broken. I'm running
Jasperserver 4.2.1 and have re-followed the guide on Icinga.org but can not
seem to get the Reporting functionality to fully work again. When I load
the Reporting cronk from within Icinga-Web, under Resources I only see
'Reload' and 'Repository', there are no select-able reports showing and
under Report details the buttons are greyed out and it says '... please
select a report from the left tree view'. Reload does appear to work, or at
least it claims it is as it dims the field and prints "Loading resource
tree...". However, if I go into the Jasperserver directly I am able to see
all the hosts and run reports from within it, but I really enjoy having the
Icinga integration and would love to find out what happened and fix it.
I've looked at my Icinga logs and don't see any errors that would indicate
a problem is occurring.

I'm not sure if this has any relevance into the Jasper integration, but
I've also apparently got a pnp4nagios issue going on where I get a bug
report every time I try to view a graph from the built in cronk. The bug
reports state:
Message: Uncaught ReferenceError: record is not defined
File: http://localhost/icing-web/modules/appkit/squishloader/javascript
Line: 52918

Hoping someone out there has an idea of where to look. Thanks in advance.

My system is Ubuntu 11.10 running:
Icinga 1.6.1
Icinga-Web 1.6.1
Icinga-Reports 1.6.0
Jasperserver 4.2.1
PNP4Nagios 0.6.16
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20120217/dbcd3dcd/attachment.html>


More information about the icinga-users mailing list