[icinga-users] ido2db and remote mysql db

Joel Salas Joel.Salas at mgo.com
Fri Mar 15 00:37:43 CET 2013


Lorenzo,

My configuration works, and it looks exactly like yours. Are you sure
you're editing the correct config file? If you're using an init script,
make sure that script points to the file you think it points to. Do a find
/ -name "ido2db.cfg" or locate ido2db.cfg and confirm that there isn't
another config file floating around.

Best,
Joel

On 3/14/13 4:30 PM, "Lorenzo Milesi" <maxxer at ufficyo.com> wrote:

>> Socket type refers to the socket that ido2db is CREATING. It does not
>> refer to the socket it will use to communicate with MySQL. Set the
>>socket
>> type to unix.
>
>ok thanks for clarifying.
>
>> Check /var/log/messages for the ido2db logging events.
>
>Still the same after changing what you suggested:
>Mar 15 00:29:25 monitor ido2db: Error: Could not connect to mysql
>database: 2002: Can't connect to local MySQL server through socket
>'/var/run/mysqld/mysqld.sock' (2)
>
>But in config I stated to use Mysql via TCP
>
>> >db_servertype=mysql
>> >db_host=10.10.10.193
>> >db_port=3306
>> >db_name=icinga_ido
>> >db_prefix=icinga_
>> >db_user=icinga
>> >db_pass="password"
>
>
>I tried manually connecting with the same parameters and works
>perfectly...
>-- 
>Lorenzo Milesi - lorenzo.milesi at yetopen.it
>
>YetOpen S.r.l. - http://www.yetopen.it/
>
>
>--------------------------------------------------------------------------
>----
>Everyone hates slow websites. So do we.
>Make your web apps faster with AppDynamics
>Download AppDynamics Lite for free today:
>http://p.sf.net/sfu/appdyn_d2d_mar
>_______________________________________________
>icinga-users mailing list
>icinga-users at lists.sourceforge.net
>https://lists.sourceforge.net/lists/listinfo/icinga-users





More information about the icinga-users mailing list