[icinga-users] Issue with icinga-mobile after change of IP

Daniel Parthey daniel.parthey at informatik.tu-chemnitz.de
Fri Mar 29 21:48:15 CET 2013


Mikael.Schmidt at ixx.se wrote:
> I'm currently working on a POC to replace current monitoring system with
> Icinga. One step is to gain simple access via smartphones using
> icinga-mobile. I had it running perfectly, then changed the IP address of the
> Icinga server and after that it doesn't work anymore. I get an error on the
> webpage saying "Missing config parameter". The text itself is hardly readable
> since it has the same colour as the background (greyish). There is only the
> greyish background, nothing to click. I've cleared the icings-web cache just
> to make sure that wasn't causing any issue, however icings-web works perfect
> after the IP address change. I've also recompiled & reinstalled icinga-mobile
> including removing /usr/local/icinga-mobile. I've also restarted the server
> just to make sure nothing was cached in memory but to no effect.
> 
> What I did after I changed the IP address was to edit
> lib/Model/IcingaConfiguration.js and replace the old IP address with the new
> IP address and ran make compile ; make install Any ideas what needs to be
> done to solve this?

Does your icinga-mobile still work from a normal browser?

If access fails from mobile only, try to ping the hostname from your mobile
and check if it already pings the new IP. Some mobile providers seem to have
long caching times (around 24h) for DNS entries. Just waiting a day might help
in this case.

Regards
Daniel
-- 
https://plus.google.com/103021802792276734820




More information about the icinga-users mailing list