[icinga-users] Icinga 2.4 does not start after update

Michael Friedrich Michael.Friedrich at netways.de
Fri Nov 20 20:34:30 CET 2015


> On 20 Nov 2015, at 19:54, Daniel Bareiro <daniel-listas at gmx.net> wrote:
>
> Hi all!
>
> I just upgraded to Icinga 2.4 using debmon.org packages. But it does not
> start. There seems to be a problem in the configuration files:
>
> -----------------------------------------------------------------------
> root at icinga2:~# systemctl status icinga2
> ● icinga2.service - Icinga host/service/network monitoring system
>   Loaded: loaded (/lib/systemd/system/icinga2.service; enabled)
>   Active: failed (Result: exit-code) since vie 2015-11-20 15:08:20 ART;
> 1s ago
>  Process: 3091 ExecStart=/usr/sbin/icinga2 daemon -e
> ${ICINGA2_ERROR_LOG} (code=exited, status=1/FAILURE)
>  Process: 3044 ExecStartPre=/usr/lib/icinga2/prepare-dirs
> /usr/lib/icinga2/icinga2 (code=exited, status=0/SUCCESS)
> Main PID: 3091 (code=exited, status=1/FAILURE)
>
> nov 20 15:08:20 icinga2 icinga2[3091]: Location: in
> /etc/icinga2/conf.d/services.conf: 47:1-47:19
> nov 20 15:08:20 icinga2 icinga2[3091]:
> /etc/icinga2/conf.d/services.conf(45):  * the custom attribute `os` set
> to `Linux`.
> nov 20 15:08:20 icinga2 icinga2[3091]:
> /etc/icinga2/conf.d/services.conf(46):  */
> nov 20 15:08:20 icinga2 icinga2[3091]:
> /etc/icinga2/conf.d/services.conf(47): apply Service "ssh" {
> nov 20 15:08:20 icinga2 icinga2[3091]: ^^^^^^^^^^^^^^^^^^^
> nov 20 15:08:20 icinga2 icinga2[3091]:
> /etc/icinga2/conf.d/services.conf(48):   import "generic-service"
> nov 20 15:08:20 icinga2 icinga2[3091]:
> /etc/icinga2/conf.d/services.conf(49):
> nov 20 15:08:20 icinga2 icinga2[3091]: [2015-11-20 15:08:20 -0300]
> critical/config: 1 error
> nov 20 15:08:20 icinga2 systemd[1]: icinga2.service: main process
> exited, code=exited, status=1/FAILURE
> nov 20 15:08:20 icinga2 systemd[1]: Unit icinga2.service entered failed
> state.
> -----------------------------------------------------------------------
>
> Although I'm not sure what is the problem because the syntax in this
> file looks correct.
>
> I would appreciate any suggestions to identify the cause of this problem.

Run the configuration validation manually and post its output.


>
> Thanks in advance.
>
> Best regards,
> Daniel
>
> _______________________________________________
> icinga-users mailing list
> icinga-users at lists.icinga.org
> https://lists.icinga.org/mailman/listinfo/icinga-users


-- 
Michael Friedrich, DI (FH)
Senior Developer

NETWAYS GmbH | Deutschherrnstr. 15-19 | D-90429 Nuernberg
Tel: +49 911 92885-0 | Fax: +49 911 92885-77
GF: Julian Hein, Bernd Erk | AG Nuernberg HRB18461
http://www.netways.de | Michael.Friedrich at netways.de

** OSMC 2015 - November - netways.de/osmc **
** OSDC 2016 - April – netways.de/osdc **


More information about the icinga-users mailing list