[icinga-users] Problem after update of icinga2

Chris Heerschap db94wookie at gmail.com
Tue Nov 24 17:28:37 CET 2015


I found the same thing upgrading to 2.4 recently - thankfully, it's an easy
fix, found the answer here:

http://www.monitoring-portal.org/wbb/index.php?page=Thread&threadID=32998

mysql -u root -p icinga2_data <
/usr/share/icinga2-ido-mysql/schema/upgrade/2.4.0.sql

where "icinga2_data" is your icinga database name.


cmh

On Tue, Nov 24, 2015 at 10:34 AM, Yann Lehmann <aristide at vtxmail.ch> wrote:

> Hi
>
> After one of the last updates of icinga2, the backend won't start anymore
> (unfortunately, I didn't notice when it went wrong).
>
> As I understand the error message of the 'checkconfig' command, this is
> due to a mismatch of the database schema (see below).
>
> [2015-11-24 16:04:57 +0100] critical/IdoMysqlConnection: Schema version
> '1.13.0' does not match the required version '1.14.0' (or newer)! Please
> check the upgrade documentation.
> Context:
>         (0) Reconnecting to MySQL IDO database 'ido-mysql'
>
> [2015-11-24 16:04:57 +0100] critical/cli: The daemon could not be started.
> See log output for details.
>
> I get a similar message in the log.
>
> What can I do to update the schema version to 1.14.0 or newer ?
>
> Thanks
> Yann
>
> PS: icinga2 runs on an Ubuntu 14.04 server and was installed from the '
> packages.icinga.org' repository
> _______________________________________________
> icinga-users mailing list
> icinga-users at lists.icinga.org
> https://lists.icinga.org/mailman/listinfo/icinga-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20151124/631554f9/attachment.html>


More information about the icinga-users mailing list