[icinga-users] Icinga can't install new node.

holo holosian at gmail.com
Sat Nov 28 12:05:26 CET 2015


Node client was in newer version than server. After upgrade of icinga2
master everything is working.
//holo
On Sat, 2015-11-28 at 11:31 +0100, holo wrote:
> Hello
> 
> I'm trying to add another node to my environment but icinga node
> wizard stops working for new instance:
> 
> Welcome to the Icinga 2 Setup Wizard!
> 
> We'll guide you through all required configuration details.
> 
> 
> 
> Please specify if this is a satellite setup ('n' installs a master
> setup) [Y/n]:
> Starting the Node setup routine...
> Please specifiy the common name (CN) [bamboo.domain.local]:  
> Please specifiy the local zone name [bamboo.domain.local]:
> Please specify the master endpoint(s) this node should connect to:
> Master Common Name (CN from your master setup): manage.domain.local
> Do you want to establish a connection to the master from this node?
> [Y/n]:
> Please fill out the master connection information:
> Master endpoint host (Your master's IP address or FQDN):
> manage.domain.local
> Master endpoint port [5665]:
> Add more master endpoints? [y/N]:
> Please specify the master connection for CSR auto-signing (defaults
> to master endpoint host):
> Host [manage.domain.local]:
> Port [5665]:
> warning/cli: Backup file
> '/etc/icinga2/pki/bamboo.domain.local.key.orig' already exists.
> Skipping backup.
> warning/cli: Backup file
> '/etc/icinga2/pki/bamboo.domain.local.crt.orig' already exists.
> Skipping backup.
> information/base: Writing private key to
> '/etc/icinga2/pki/bamboo.domain.local.key'.
> information/base: Writing X509 certificate to
> '/etc/icinga2/pki/bamboo.domain.local.crt'.
> information/cli: Fetching public certificate from master
> (manage.domain.local, 5665):
> 
> warning/TlsStream: OpenSSL error: error:14094410:SSL
> routines:SSL3_READ_BYTES:sslv3 alert handshake failure    
> critical/cli: Peer did not present a valid certificate.
> 
> Should i unlock some other port than  5665? Where could be problem,
> on other  instances it was working without any problem.
> 
> Regards
> holo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.icinga.org/pipermail/icinga-users/attachments/20151128/934bb953/attachment.html>


More information about the icinga-users mailing list