[icinga-users] Error running icinga2 v2.9.0

Jered Floyd jered at convivian.com
Sun Jul 22 19:22:23 CEST 2018


Usman,

This issue was raised by another user yesterday -- Peter Eckel suggested reviewing the upgrading notes regarding sysconfig at https://www.icinga.com/docs/icinga2/latest/doc/16-upgrading-icinga-2/

He also noted that 2.9.0 had issues on non-systemd machines and that a more recent snapshot may help.

This all creates a wishlist for me regarding package managers -- on Debian it's never apparent when an upgrade should require careful review of documentation due to the potential for breaking changes.  I wish there was a flag so that apt-get would say "no, dummy, go read the notes first!"  Creating new dummy package dependencies can have this effect, but it's definitely not the right way to do it.

--Jered

----- On Jul 22, 2018, at 12:06 PM, Usman Haider uhaider.msee15seecs at seecs.edu.pk wrote:

> Hi,
> 
> I am using icinga2 v2.9.0-26 on SLE12. When I start the service I an
> getting the error
> 
> critical/config: Error: Could not load library 'libmysql_shim.so.2.9.0':
> 
> Complete output is on the following link
> 
> https://pastebin.com/3hvqFrBp
> 
> 
> Thanks
> _______________________________________________
> icinga-users mailing list
> icinga-users at lists.icinga.org
> https://lists.icinga.org/mailman/listinfo/icinga-users


More information about the icinga-users mailing list