[icinga-users] Error running icinga2 v2.9.0

Michael Friedrich michael.friedrich at icinga.com
Mon Jul 23 17:33:02 CEST 2018



> On 22. Jul 2018, at 18:06, Usman Haider <uhaider.msee15seecs at seecs.edu.pk> wrote:
> 
> Hi,
> 
> I am using icinga2 v2.9.0-26 on SLE12. When I start the service I an
> getting the error
> 
> critical/config: Error: Could not load library 'libmysql_shim.so.2.9.0':
> 
> Complete output is on the following link
> 
> https://pastebin.com/3hvqFrBp
> 

Any specific reason not to rebuild the SRPMs from our repository since you want to build in a special architecture?

2.9 changed several build parameters internally and introducing new library files released in the packages. As you may figure, we don’t officially support custom source compilations mainly for not having to take care during development cycles on such things. The packages available on packages.icinga.com apply and provide best practices for building Icinga 2, you can extract such from the spec file provided inside the SRPM.

Cheers,
Michael


More information about the icinga-users mailing list