[icinga-users] check_procs not reporting a process running that it is checking for

Volker Janzen voja at voja.de
Tue Oct 2 09:09:21 CEST 2018


Hi,

you need to tell the check which and for how many processes to look for. 
When looking for a specific process when using apply Service add:

vars.procs_critical = "1:1"
vars.procs_user = "nobody"
vars.procs_command = "smokeping"


   Volker

Am 2018-10-02 02:02, schrieb Botnick, Steven:
> Hello,
> 
> I have an icinga instance running on each of two systems and checks on
> each system for certain  processes running. System 2 is performing the
> same check on itself as system 1, yet system 2 check fails to report
> the process is running.
> 
> system #1:
> 
> check_procs v1.5 (nagios-plugins 1.5)
> 
> ps:  ... 00:05:14 /usr/local/smokeping/bin/smokeping [FPing]
> 
> # /usr/local/icinga/libexec/check_procs -v
> PROCS OK: 135 processes | procs=135;;;0;
> 
> system #2:
> 
> check_procs v1.5 (nagios-plugins 1.5)
> 
> ps ..  00:15:53 /usr/local/smokeping/bin/smokeping [FPing]
> 
> # /usr/local/icinga/libexec/check_procs -C smokeping
> PROCS OK: 0 processes with command name 'smokeping' | procs=0;;;0;
> 
> There are other process checks running on the host and they are
> operating normally.
> Any ideas? TIA for anything helpful.
> 
> --Steve
> _______________________________________________
> icinga-users mailing list
> icinga-users at lists.icinga.org
> https://lists.icinga.org/mailman/listinfo/icinga-users


More information about the icinga-users mailing list